Home > Error Could > Error Could Not Find Xopendisplay In

Error Could Not Find Xopendisplay In

You seem to have CSS turned off. Please don't fill out this field. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 300 Star 1,443 Fork 1,522 PointCloudLibrary/pcl Code Issues 209 Pull requests 66 Projects Expected them to be in /usr/lib. check over here

This is free software; see the source for copying conditions. E-Maculation Forum Index Switch to mobile style Powered by phpBB Forum Software © phpBB Group FAQ Forum Quick Links Unanswered Posts New Posts View Forum Leaders FAQ Contact an Admin Forum [email protected]:/sources/ccode/test# gcc main.c -o main.exe -l X11.so /usr/bin/ld: cannot find -lX11.so collect2: ld returned 1 exit status [email protected]:/sources/ccode/test# ls main.c main.o main.s X11.a X11.so Adv Reply April 12th, 2010 #3 Sorry if I don't make sense. my review here

This is my cmake output: -- The C compiler identification is GNU 4.7.3 -- The CXX compiler identification is GNU 4.7.3 -- Check for working C compiler: /usr/bin/cc -- Check for Chesterton > > -- > ubuntu-users mailing list > ubuntu-users at lists.ubuntu.com > http://lists.ubuntu.com/mailman/listinfo/ubuntu-users > Previous message: compiling pearpc Next message: Ubuntu killed my HD?? How to I fix this broken path? Ubuntu Logo, Ubuntu and Canonical Canonical Ltd.

Terms Privacy Security Status Help You can't perform that action at this time. Adv Reply Quick Navigation General Help Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums The Ubuntu Forum Community Ubuntu Official Flavours Support New to no checking for catopen... y -- The C compiler identification is GNU 4.7.3 -- The CXX compiler identification is Clang 3.2.0 -- Check for working C compiler: /usr/bin/cc -- Check for working C compiler: /usr/bin/cc

This Stack Overflow comment seems to mean that you can't make shared libraries with -fPIE - maybe that's the problem? (I tried to just remove the -fPIE -fPIE -fPIE -fPIE -fPIE You signed out in another tab or window. noconfigure: error: Could not find XOpenDisplay in -lX11...I found few identical emails regarding same problems after google searchbut without any solutions.Is this problem still open ? why not find out more I'm on Ubuntu 13.04 64 bit.

Please don't fill out this field. no checking for gethostbyname in -lbsd... Join Date Apr 2007 Location Munich, Germany Posts 1 thank you for posting the solution. Stop.

For details and our forum data attribution, retention and privacy policy, see here [email protected] Discussion: Could not find XOpenDisplay ...again (too old to reply) Bruno Costacurta 2007-12-31 23:31:52 UTC PermalinkRaw I am using the --x-libraries and --x-includes flags pointing to the install dir of libX11. I personally don't want to have to install it considering that the two, Xfree86/Xserver [freedesktop] don't get along well... no checking for vsnprintf...

Can't find XOpenDisplay! [SOLVED] Alright, I've been working on this for longer than I can remember. http://strobelfilms.com/error-could/error-could-not-find-the-gpg-key-necessary-to-validate.html no checking for shmat in -lipc... Home Forum Today's Posts | FAQ | Calendar | Community Groups | Forum Actions Mark Forums Read | Quick Links View Site Leaders | Unanswered Posts | Forum Rules Articles Marketplace Join Date May 2005 Location Kokomo, IN Posts 58 GTK+ won't compile.

make: *** No targets specified and no makefile found. The time now is 10:42 AM. If this is your first visit, be sure to check out the FAQ by clicking the link above. this content Is there some kind of dependency libX11 needs to compile with XOpenDisplay that I don't have?

Login • Register The time is now: Sat Dec 24, 2016 10:42 am Emaculation wiki • Delete all board cookies E-Maculation Forum Index Information The requested topic does not exist. Sign in to comment Contact GitHub API Training Shop Blog About © 2016 GitHub, Inc. no checking for t_open in -lnsl...

Already have an account?

Reload to refresh your session. As I copied the libraries to local directory and still get same error. Someversionsofautoconf/makeareabitpickyaboutthethingsone putsinthelibrarycheckingmacro. > >Doesanyoneknowhowtofixthis? It turns out you need to have libXext installed before trying to compile GTK+. 04-20-2007 #3 nazgul77 View Profile View Forum Posts Private Message View Articles Just Joined!

no checking for gethostbyname in -lnsl... this is not obvious since I had libX11-dev installed, too. $spacer_open $spacer_close Quick Navigation Applications Top Site Areas Settings Private Messages Subscriptions Who's Online Search Forums Forums Home Forums Linux Forums Perhaps you may contact the people who had the problem and ask how did they end up solving it. have a peek at these guys Messages sorted by: [ date ] [ thread ] [ subject ] [ author ] More information about the ubuntu-users mailing list Skip to content Ignore Learn more Please note

no checking for snprintf...