Home > Error Could > Error Could Not Find Python Module Gtk

Error Could Not Find Python Module Gtk

comment:4 Changed 9 years ago by [email protected]… Cc [email protected]… added; [email protected]… removed Status changed from new to assigned I am perpetually incapable of reproducing (or even producing) this error. The contents of this document, unless otherwise expressly stated, are licensed under the CC-BY-SA-3.0 license. no configure: error: Could not find Python module gtk The problem still exists, though it may not be sourced in the avahi port. yes checking for python... /usr/bin/python checking for pygtk... check over here

log as per instructions (compressed due to sized constraints) avahi.install.log.2.zip​ (33.3 KB) - added by [email protected]… 9 years ago. But somehow, I have a feeling that you don't have one set up, and don't know how. Find More Posts by ponce 02-04-2014, 05:06 PM #7 brooko Member Registered: Nov 2009 Posts: 35 Original Poster Rep: Quote: look for the config.log in the avahi source dir Also, you have to be precise with names. https://trac.macports.org/ticket/12966

Just unpack Variety's tar somewhere, install the external dependencies (listed in debian/control), and then directly run bin/variety. Maybe the macro is checking Python 3 for module Pygtk?Btw, you'll have another problem when you solve that. Slackbuilds always assume a full installation. yes > checking whether /opt/local/bin/python2.5 version >= 2.4...

Now when I try help('modules') I have different error and python freezes. If you install the external dependencies (listed in debian/control) you should be able to run Variety even without running setup.py. yes checking for python module dbus... Subscribed!

My advise would be to not do help('modules') as it tries to load everything which is installed in python, and thus will have undefined behavior. –dobey Nov 9 '12 at 19:27 LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware [SOLVED] SBo avahi missing python module gtk User Name Remember Me? If you it says "2.3", you need to install "python_select" port, run python_select python25 comment:2 Changed 9 years ago by [email protected]… This gives files in /opt/local/lib/python2.5/site-packages/gtk-2.0 (no files with 2.3 in https://lists.gnucash.org/pipermail/gnucash-user/2007-November/022638.html yes > checking for GLIB20...

no configure: error: Could not find Python module gtk All the python-related dependencies are installed and active: $ port installed | grep py dbus-python25 @0.82.2_0 (active) py-bsddb @2.4.3_1 py-bsddb @2.4.4_0 (active) not found configure: error: Python headers not found How can i resolve this error, please suggest ? your right, but the answer might be there... –IronManMark20 May 6 '15 at 1:36 | show 3 more comments 2 Answers 2 active oldest votes up vote 1 down vote I However, I am trying to install the GTK liberty and I am running into a lot of problems.

Or, alternatively, install Bazaar and run bzr branch lp:variety – this means you will be running from the latest trunk development version (which I try to keep stable). 2. yes > checking expat.h usability... In a long error log, apart of other stuff I have: pkg-config: looking for pygtk-2.0 gtk+-2.0 * Package pygtk-2.0 was not found in the pkg-config * search path. So I don't know if just adding the pygtk stuff will work for you.

However in the past when I've done partial/custom installs I've been able to figure out where the missing dep is via slackpkg search or looking through the manifest to see what check my blog up vote 0 down vote I believe that your problem is that you're trying to find non-Python prerequisites via pip. checking for NAUTILUS... If that isn't "it", then excuuuuuuuuuse me. Last edited by Habitual; 02-03-2014 at 05:05 PM.

Perhaps you should add the directory * containing `pygtk-2.0.pc' to the PKG_CONFIG_PATH * environment variable No package 'pygtk-2.0' found * Package gtk+-2.0 was not found in the pkg-config * search path. This is probably something simple I'm just overlooking ... Would presence of MANPADS ground the entire airline industry? this content Please visit this page to clear all LQ-related cookies.

Comment: Using GnuPG with undefined - http://www.enigmail.net/ iQIcBAEBCgAGBQJQr2oEAAoJEE21PP6CpGcoiLwP/3KjgSwLmirZWUnzY6RYWGra Q+K6T4dkGtfObzDEv8Jjz3cQy9WrMET1FaY9W1B/O7Yu6JXtCGkj1EXCuZL6ki0H pVJqY5zuiL3Th5Amu7rmctOnODiv1d5zDnvAK5DWP52qBX/3uKcrskTCfonTAyJ9 Yn3klLg1pZFUtHLF7KLj+sc5RpedMQGTowgEqqbkXj7IhsirDzSlzz02XhYV4tPN rpkdW4eioxjQAkHFXr0CDACApPAyRrYB1HseRCp960VqZb/wfV8NK1k1p+S+f/Il 7GnxvNa2Jv8GbFmO+kiuicpmzCPhl39I1/2newRQp7gDIaJFfDiykdyJBGxPPHPB QMEsDfzju2iNZvgPl0UuN+PQA0b68wH+eiuA6Ni+bZn2lb7Fw4W0ceMctwOe1FyQ oexeM5UGsnZlwoNzP1UnIH9bvDeE+oiEUxsie+4xEc2nBdDvzN8BV6yzuIa+emBi ZUFQNfbA4Wt+g57Rjh3uYrCc3sYRd0XOuqR1d/VqcJAniEnHf4sySKcrw8gN+nDo sJi7o/ka3bT1ZnkRpsp8e/hhkZVrgk/3DtluZnLKFRd2sMGvs+xjTJKSK+Ufazzd 2EMM6Rp7p+wVtdtGTBnHDOOWWDsnW5jjNdeQGg2fHrEauy4oiE1wtW9AjCQ3n+Ie QcNAdp78PkM/8CCNFyjy =KOo3 -----END PGP SIGNATURE----- Peter Levi (peterlevi) said on 2012-11-23: #3 1. configure:3073: $? = 0 configure:3062: gcc -v >&5 Using built-in specs. Will try to work out about this libraries, hopefully it will not cause any major problems. –tomasz74 Nov 9 '12 at 20:19 add a comment| Your Answer draft saved draft

Is Quickly available for Debian? 2.

the update to 12.04 removes it. (cannot go python2.7 because of specific extensions)0Ubuntu 12.04 menu bar, nautilus, terminal, and gtk themes not working after installation of Gimp 2.81Why doesnot my software configure:3073: $? = 1 configure:3062: gcc -qversion >&5 gcc: error: unrecognized option '-qversion' gcc: fatal error: no input files compilation terminated. I applied a simple workaround to many python ports whose makefiles make use of the flag "-export-symbol-regex" by simply removing it and so making the missing symbols public again. I've installed and ran the python_select port (I'm assuming this is symbol export workround) and tried several times uninstalling and installing these packages - and every time avahi fails with the

python gtk gobject share|improve this question asked Mar 4 '13 at 11:26 Allan 3711725 You'll need to (correctly) install the python development package. I'm too cold, turn up the temperature Is there a non-medical name for the curve where index finger and thumb meet? You'll have to change all #!/usr/bin/python headers to #!/usr/bin/python2. have a peek at these guys share|improve this answer answered May 6 '15 at 1:38 IronManMark20 759424 When I try to install I get a message saying that "Python version 2.7 required, which was not

Contact Us - Advertising Info - Rules - LQ Merchandise - Donations - Contributing Member - LQ Sitemap - Main Menu Linux Forum Android Forum Chrome OS Forum Search LQ pogma is reporting on his blog that using the new libtool 1.5.26 instread of the Apple's one can alleviate such troubles: ​http://pogma.com/2008/02/13/nmedit-libtool-exported-symbols/. darwin checking for /opt/local/bin/python2.5 script directory... ${prefix}/lib/python2.5/site-packages checking for /opt/local/bin/python2.5 extension module directory... ${exec_prefix}/lib/python2.5/site-packages checking for python module gtk... If you're missing pkg-config, installing something called pyconfig isn't going to help; they have nothing to do with each other.

I don't know a solution however. You are currently viewing LQ as a guest. Success! But see bug #13225.

Not the answer you're looking for? yes > checking for GLADE20... I have now installed them and variety starts. Why wouldn't the part of the Earth facing the Sun a half year before be facing away from it now at noon?

Offline Pages: 1 Topic closed Index »Applications & Desktop Environments »[SOLVED] Pygtk not found when building Dropbox Board footer Jump to Newbie Corner Installation Kernel & Hardware Applications & Desktop Environments I've build all the of the Gnucash > dependencies > successfully except Avahi; I get the following output/error. It should automagically install all of the dependencies for pyGTK. Please wait...

I don't know how those work now when Arch is using Python3 as default. Maybe its my misunderstanding the "slackpkg install PATTERN" but i thought the following would install all the above libX* libs since "slackpkg search libX" found them.... Offline #18 2013-09-04 12:07:58 adept Member Registered: 2013-09-04 Posts: 1 Re: [SOLVED] Pygtk not found when building Dropbox i have the same problem. To someone, it may be better than you dare to think.Blog Offline #9 2011-08-14 11:06:25 RichAustin Member From: Wakefield, Yorkshire, England Registered: 2011-07-27 Posts: 186 Re: [SOLVED] Pygtk not found when

really appreciated. Sever-sort an array Making identical C++ type aliases incompatible How to select a number from all the integers list? On a Linux distro this is usually solved via installing python-dev or a similar package. And you might break some dependencies along the way.