Home > Error Could > Error Could Not Find Libpcre

Error Could Not Find Libpcre

Contents

How can I turn rolled oats into flour without a food processor? Does gunlugger AP ammo affects all armor? Found apxs2 sbin: /usr/bin/apxs2 ===> Applying patch - apxs2 module version name ... ===> Configuring 5.4.22... configure: error: Could not find libpcre.(a|so) in /usr--------------------------------------------------------------------------Edit this bug report at https://bugs.php.net/bug.php?id=64617&edit=1 reply | permalink Ab Edit report at https://bugs.php.net/bug.php?id=64617&edit=1 ID: 64617 Updated by: [email protected] Reported by: [email protected] check over here

This will also save you from symlinking to /usr. I did try compiling a new version of icon since I couldn't get the native one to work for this. pejman, Aug 28, 2015 #10 Pong Member Staff Member For php 5.4.x or lower version, APC can be used for Opcode cache as well as Value cache. Were Palpatine or Vader ever congratulatory or nice to any of their subordinates?

Configure: Error: Please Reinstall The Bzip2 Distribution

LiteSpeed Cache is httpd level of file/page cache, like Apache_mod_cache or Varnish, different than Xcache/Opcache/APC. This is my PHPBrew command: phpbrew install 5.5.5 +default+mysql+pdo+apxs2 Wich results in the following configure options being generated: ./configure '--prefix=/home/malte/.phpbrew/php/php-5.5.5' '--with-config-file-path=/home/malte/.phpbrew/php/php-5.5.5/etc' '--with-config-file-scan-dir=/home/malte/.phpbrew/php/php-5.5.5/var/db' '--with-pear=/home/malte/.phpbrew/php/php-5.5.5/lib/php' '--disable-all' '--enable-phar' '--enable-session' '--enable-short-tags' '--enable-tokenizer' '--with-pcre-regex' '--with-zlib=/usr' '--with-libdir=lib/i386-linux-gnu' It installed properly, but still showed me a similar error.

alanhartless commented Dec 8, 2013 (after a self-update) Member c9s commented Dec 8, 2013 autoscript didn't bump the version, but I think it's the latest one. Member c9s commented Dec 8, 2013 OK I just fix the libdir detection at 8eb9bc0, please run self-update to get 1.11.3 alanhartless commented Dec 8, 2013 Oops; I did self update pejman New Member Hello guys, I am trying to compile php 5.4.4 via admin panel but every time i receive an error, I read all troubleshooting guides on LiteSpeed Wiki but This is under Ubuntu 13.10 (not seeing the same problems on 12.04).

Unix & Linux Stack Exchange works best with JavaScript enabled current community chat Stack Overflow Meta Stack Overflow your communities Sign up or log in to customize your list. Ubuntu Install Pcre What are these boxes mounted inline on each of the 3 phase wires of a high voltage power line in Miami? I'm not sure since not familiar with Plesk. https://bugs.php.net/bug.php?id=64617 patch unexpectedly ends in middle of line Hunk #2 succeeded at 41745 with fuzz 1 (offset 350 lines).

Member c9s commented Dec 8, 2013 php -m to see if iconv is loaded If not, try phpbrew ext enable iconv [Sent from iPhone] devkardia [email protected] ©ó 2013/12/8 15:17 ¼g¹D¡G I Use tail command to see what's going on: $ tail -f /opt/phpbrew/build/php-5.4.22/build.log ./configure '--prefix=/opt/phpbrew/php/php-5.4.22' '--with-config-file-path=/opt/phpbrew/php/php-5.4.22/etc' '--with-config-file-scan-dir=/opt/phpbrew/php/php-5.4.22/var/db' '--with-pear=/opt/phpbrew/php/php-5.4.22/lib/php' '--disable-all' '--enable-phar' '--enable-session' '--enable-short-tags' '--enable-tokenizer' '--with-pcre-regex' '--with-zlib=/usr' '--with-libdir=lib/i386-linux-gnu' '--enable-gd-native-ttf' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-freetype-dir=/usr' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' I already solved a ton of problems in the process, but with this particular one I can't get any further. The difference between 'ping' and 'wget' in relation to hostname resolution Unsold Atari videogames dumped in a desert?

Ubuntu Install Pcre

How to include module's CSS in CMS pages with module block What is the truth about 1.5V "lithium" cells When hiking, why is the right of way given to people going find /usr/ -name "libpcre.so" /usr/lib/i386-linux-gnu/libpcre.so /usr/local/lib/libpcre.so find /usr/ -name "pcre.h" /usr/include/php5/ext/pcre/pcrelib/pcre.h /usr/include/pcre.h /usr/local/include/pcre.h I'm on Ubuntu 12.04 32bit phpbrew - 1.11.2 cliframework core: 1.5.12 I've been able to install other versions Configure: Error: Please Reinstall The Bzip2 Distribution How to select a number from all the integers list? NiteWave, Aug 23, 2015 #4 pejman New Member Hi NiteWave, Thank you for the help but i also tested that command : Code: [email protected]:~# apt-get install pcre-devel Reading package lists...

Also pcre-devel or pcre-dev package. check my blog Configure: error: Could not find libpcre.(a|so) in /usr/include
fix: "-\-\with-pcre-regex=/usr" \\
More: http://www.lifelinux.com/error-compiling-php-on-centos-x64/

A Page of Puzzling How to select a number from all the integers list? Previous Comments Ab at Jun 6, 2013 at 5:43 pm ⇧ Edit report at https://bugs.php.net/bug.php?id=64617&edit=1ID: 64617Updated by: [email protected] by: [email protected]: --with-pcre-regex doesn't scan subdirectoriesStatus: FeedbackType: BugPackage: PCRE relatedOperating System: unixPHP Version: phpbrew -d install 5.4.22 +iconv +gd should work for you. this content DirectAdmin 2013 JBMC Software current community chat Unix & Linux Unix & Linux Meta your communities Sign up or log in to customize your list.

When hiking, why is the right of way given to people going up? Didn't even have to use --with-pcre afterwards. Copyright © 2001-2016 The PHP Group All rights reserved.

Fields that can be ordered in more than one way How to find punctures in inner tubes?

alanhartless commented Dec 8, 2013 I tried that and compilation errors out: [email protected]:/home/alan# phpbrew -d install php-5.4.22 +default +gd +mysql +gettext +mcrypt +intl +iconv +ftp=shared +exif +dba +openssl +soap +ipv6 +imap To start viewing messages, select the forum that you want to visit from the selection below. Try this (this is for Debian lenny, but may also work for you): sudo aptitude install libpcre3 libapr1 libaprutil1 (In this case, apparently the -dev versions are not necessary; I don't so you don't have to append the raw configure options to command line.

The distribution of CentOS I'm running only allows for yum upgrades to version 6.6, or somewhere similar. Explain it to me like I'm a physics grad: Greenhouse Effect What does this symbol of a car balancing on two wheels mean? Check the configure/ap2/configure.php5 file I Verified ZLIB is installed correctly. [Via CustomBuild] edit: This fixed my problem!! have a peek at these guys be killed in the war vs be killed by the war How would people living in eternal day learn that stars exist?

Check the configure/ap2/configure.php5 file For the second one : #!/bin/sh ./configure \ --with-apxs2 \ --with-curl=/usr/local/lib \ --with-gd \ --enable-gd-native-ttf \ --with-ttf \ --with-gettext \ --with-jpeg-dir=/usr/local/lib \ --with-freetype-dir=/usr/local/lib \ --with-kerberos \ --with-openssl You can enable repos with yum-config-manager --enable pejman, Aug 23, 2015 #3 NiteWave Administrator Hi, please refer https://www.litespeedtech.com/support/wiki/doku.php/litespeed_wiki:php:lsapi-troubleshooting if you run Ubuntu, should use apt-get instead of yum. more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed connected.

Configure: error: Could not find pcre.h in /usr/local
fix: "-\-\with-pcre-regex=/usr/include" \\
5. Please read the documentation. Why did Sansa refuse to leave with Sandor Cleagane (Hound) during the Battle of Blackwater? Actual result: -------------- checking for PCRE library location...

What does the author want to convey by ending his letter with »Tschüssikowsky«? What's the difference between ls and la? It works.Also i wouldn't say this is a bug, looking into non standard dirs is ignored by many projects.sorry, I just don't have much experience and I don't know that /usr/lib/x86-64-linux-gnu/ Writing variant info to /opt/phpbrew/php/php-5.4.22/phpbrew.variants Build Directory: /opt/phpbrew/build/php-5.4.22 PHP Version lower than 5.4.0 can only build one SAPI at the same time. +apxs2 is in conflict with cgi Disabling cgi PHP

Found existing php-5.4.22, Skip extracting. I guess the default prefix on Ubuntu Linux should be "/usr", not "/usr/local". Why did Tarkin undertake this course of action at the end of Rogue One? This is from the this file http://archive.ubuntu.com/ubuntu/pool/main/p/php5/php5_5.3.2-1ubuntu4.dsc Build-Depends: apache2-prefork-dev, autoconf (>=2.63), automake (>=1.11) | automake1.11, bison, chrpath, debhelper (>=5), flex, freetds-dev, hardening-wrapper, libapr1-dev (>=1.2.7-8), libbz2-dev, libcurl4-openssl-dev, libdb-dev (>=4.7) | libdb4.8-dev |

Xcache or LS built in cache engine? Should work now. –daemonaka Dec 19 '14 at 14:46 Works fine for RedHat 6, too. –Halmackenreuter Feb 11 '15 at 11:09 add a comment| up vote 1 down vote