Home > Error Could > Error Could Not Find Libpcre.a So In /usr

Error Could Not Find Libpcre.a So In /usr

Contents

To viewthe rest of the comments, please view the bug report online athttps://bugs.php.net/bug.php?id=64617--Edit this bug report at https://bugs.php.net/bug.php?id=64617&edit=1 reply | permalink Ab Edit report at https://bugs.php.net/bug.php?id=64617&edit=1 ID: 64617 Updated by: [email I also tried to add "EXTRACFLAGS=-fPIC" to make, but it wouldn't change anything. To start viewing messages, select the forum that you want to visit from the selection below. anyway, why not have a try ? check over here

Check the configure/ap2/configure.php5 file For the second one : #!/bin/sh ./configure \ --with-apxs2 \ --with-curl=/usr/local/lib \ --with-gd \ --enable-gd-native-ttf \ --with-ttf \ --with-gettext \ --with-jpeg-dir=/usr/local/lib \ --with-freetype-dir=/usr/local/lib \ --with-kerberos \ --with-openssl Browse other questions tagged php make configure or ask your own question. What is a real-world metaphor for irrational numbers? Forum New Posts FAQ Calendar Forum Actions Mark Forums Read Quick Links Today's Posts View Site Leaders Advanced Search Forum Technical Discussion General Technical Discussion & Troubleshooting Problem with PHP installation. i thought about this

Configure: Error: Please Reinstall The Bzip2 Distribution

Member c9s commented Dec 8, 2013 found why, so if we specify with --with-iconv=/usr it found giconv instead of the correct libiconv but if you omit the option value or assign configure: error: Could not find libpcre.(a|so) in /usr # dpkg -l |g pcre ii libpcre3 8.12-3ubuntu2 Perl 5 Compatible Regular Expression Library - runtime files ii libpcre3-dev 8.12-3ubuntu2 Perl 5 Compatible Powered by vBulletin Version 4.2.3 Copyright © 2016 vBulletin Solutions, Inc. NiteWave, Aug 23, 2015 #4 pejman New Member Hi NiteWave, Thank you for the help but i also tested that command : Code: root@test:~# apt-get install pcre-devel Reading package lists...

All Rights Reserved. (Privacy Policy) php.net| support| documentation| report a bug| advanced search| search howto| statistics| random bug| login go to bug id or search bugs for Bug#64617 --with-pcre-regex doesn't scan I've since uninstalled it, deleted the php-5.4.22 source directory so its a clean compile, and reran phpbrew's install command. Is there a better and easy way of building PHP from source? patching file configure Hunk #1 succeeded at 39388 (offset 175 lines).

Previous Comments Ab at Jun 6, 2013 at 5:43 pm ⇧ Edit report at https://bugs.php.net/bug.php?id=64617&edit=1ID: 64617Updated by: ab@php.netReported by: php@paulisageek.comSummary: --with-pcre-regex doesn't scan subdirectoriesStatus: FeedbackType: BugPackage: PCRE relatedOperating System: unixPHP Version: extension_dir=/usr/lib/php/modules extensionは指定した所を見るようになったが、 そもそも、使えるモジュールじゃない? 今日は諦めて元戻すか。今度リベンジする。 yum removeで一回全部消した。 ・php ・php-common ・php-cli ・php-mcrypt ・php-ldap ・php-mbstring ・php-mysql ・php-pdo ・php-pear ・php-soap ・php-xml たぶん復活。 投稿者 Tatsuya Karino 時刻: 3:36 メールで送信BlogThis!Twitter で共有するFacebook で共有するPinterest に共有 ラベル: PHP 0 件のコメント: Use tail command to see what's going on: $ tail -f /opt/phpbrew/build/php-5.4.22/build.log ./configure '--prefix=/opt/phpbrew/php/php-5.4.22' '--with-config-file-path=/opt/phpbrew/php/php-5.4.22/etc' '--with-config-file-scan-dir=/opt/phpbrew/php/php-5.4.22/var/db' '--with-pear=/opt/phpbrew/php/php-5.4.22/lib/php' '--enable-xml' '--disable-all' '--enable-phar' '--enable-session' '--enable-short-tags' '--enable-tokenizer' '--with-pcre-regex' '--with-zlib=/usr' '--with-libdir=lib/i386-linux-gnu' '--with-mysql=mysqlnd' '--with-mysqli=mysqlnd' '--with-pdo-mysql=mysqlnd' '--with-gettext=/usr' '--with-mcrypt=/usr' https://bugs.php.net/bug.php?id=64617 Did Donald Trump say that "global warming was a hoax invented by the Chinese"?

Newer Than: Search this thread only Search this forum only Display results as threads Useful Searches Recent Posts More... configure: error: Could not find libpcre.(a|so) in /usrClick to expand... Try adding -L/usr/lib/x86_64-linux-gnu to LDFLAGS of php. Member c9s commented Dec 8, 2013 The configure script found your pcre.h in /usr/local/include, but it seems like can't get the location of your pcre.so or pcre.a file.

Ubuntu Install Pcre

McClane is a NYPD cop. http://unix.stackexchange.com/questions/105927/compiling-php-fails-cause-of-libpcre Member c9s commented Dec 8, 2013 Ok i know why configure can not find libiconv, because its required by gd! Configure: Error: Please Reinstall The Bzip2 Distribution configure: error: Could not find libpcre.(a|so) in /usr--------------------------------------------------------------------------Edit this bug report at https://bugs.php.net/bug.php?id=64617&edit=1 reply | permalink Ab Edit report at https://bugs.php.net/bug.php?id=64617&edit=1 ID: 64617 Updated by: [email protected] Reported by: [email protected] Is the effect of dollar sign the same as textit?

Check the configure/ap2/configure.php5 file Thank YOU! check my blog libpcre.so) which are built with -fPIC. Done E: Unable to locate package pcre-devel pejman, Aug 23, 2015 #5 pejman New Member I used command : apt-cache search pcre These packages listed, which should be installed? Splitting a line into two Is it bad form to write mysterious proofs without explaining what one intends to do?

root@server:/home/alan# phpbrew -d install php-5.4.22 +default +mysql +gettext +mcrypt +intl +iconv +ftp +exif +dba +openssl +soap +ipv6 +imap +debug +cgi +apxs2=/usr/bin/apxs2 -- --with-libdir=lib/i386-linux-gnu --with-gd=shared --enable-gd-native-ttf --with-jpeg-dir=/usr --with-png-dir=/usr --enable-wddx --with-mysql-sock=/var/run/mysqld/mysqld.sock --with-freetype-dir=/usr/include/freetype2/freetype --with-openssl Please check your libxml2 installation.Fix: yum install libxml2 libxml2-devel# aptitude install libxml2-dev (For ubuntu) 2.Error: configure: error: Cannot find OpenSSL’sFix: yum install openssl openssl-devel 3.Error: Configure: error: Please reinstall the BZip2 This is my PHPBrew command: phpbrew install 5.5.5 +default+mysql+pdo+apxs2 Wich results in the following configure options being generated: ./configure '--prefix=/home/malte/.phpbrew/php/php-5.5.5' '--with-config-file-path=/home/malte/.phpbrew/php/php-5.5.5/etc' '--with-config-file-scan-dir=/home/malte/.phpbrew/php/php-5.5.5/var/db' '--with-pear=/home/malte/.phpbrew/php/php-5.5.5/lib/php' '--disable-all' '--enable-phar' '--enable-session' '--enable-short-tags' '--enable-tokenizer' '--with-pcre-regex' '--with-zlib=/usr' '--with-libdir=lib/i386-linux-gnu' this content I'm trying to get gd installed but I'm getting this error after installing it: PHP Warning: PHP Startup: Unable to load dynamic library '/opt/phpbrew/php/php-5.4.22/lib/php/extensions/debug-non-zts-20100525/gd.so' - /opt/phpbrew/php/php-5.4.22/lib/php/extensions/debug-non-zts-20100525/gd.so: undefined symbol: libiconv_open in Unknown

If you need a newer version you might check to see if a newer release is in the unstable branch and try back-porting it. Xcache has php opcode cache as well as some variable cache. Gotta grab it again. :-) alanhartless commented Dec 8, 2013 Okay; snagged it again.

Results 1 to 11 of 11 Thread: Problem with PHP installation. [with CustomBuild] Thread Tools Show Printable Version Email this Page… Display Linear Mode Switch to Hybrid Mode Switch to Threaded

so you don't have to append the raw configure options to command line. alanhartless commented Dec 8, 2013 I ran phpbrew lookup-prefix /usr and now I'm getting a message that I must reinstall iconv. As you scroll down on that page you can see a list of all the build dependencies for the official package. I'm not sure since not familiar with Plesk.

You signed out in another tab or window. Zend opcache has PHP opcode cache only. When I run grep command, I get: /* #undef COMPILE_DL_ICONV / / #undef HAVE_BSD_ICONV / / #undef HAVE_GICONV_H / #define HAVE_GLIBC_ICONV 1 / #undef HAVE_IBM_ICONV / #define HAVE_ICONV 1 / #undef have a peek at these guys Test script: --------------- ./compile --with-pcre-regex=/usr Expected result: ---------------- It compiles.

I'm getting this error message in the make process: /usr/bin/ld: /usr/libpcre.a(pcre_exec.o): relocation R_X86_64_32S against `_pcre_ucd_stage1' can not be used when making a shared object; recompile with -fPIC /usr/libpcre.a: error adding symbols: This site is not affiliated with Linus Torvalds or The Open Group in any way. Last updated: Sat Dec 24 10:01:49 2016 UTC Register Help Remember Me? To build the package yourself you are probably going to need to install everything in that list before you will be able to perform compile the source using a similar set

Please reinstall libmcrypt.Fix: yum install libmcrypt-devel # apt-get install libmcrypt-dev 14) Configure: error: snmp.h not found. Not the answer you're looking for? Defendant"? Please check your libxml2 installation.
fix: yum install libxml2-devel.x86_64
2.

Thanks for sharing the workarounds ;) Sign up for free to join this conversation on GitHub. When i tried ./configure --prefix=/usr/local/apache --enable-so, I got: configure error - apr not found apr-util not found.. Whats the solution for this? share|improve this answer edited Dec 19 '13 at 21:18 answered Dec 19 '13 at 18:31 casey 9,81022353 Perfect.

I use Centos7.1 64 bit with Plesk CP and PHP 5.5.28 pejman, Aug 29, 2015 #16 NiteWave Administrator You can PM me root access to your server, and access to I solved the following option. --with-libdir=lib/x86_64-linux-gnu GulDmitry commented Feb 20, 2014 Ubuntu 12.10. Run "yum repolist all" to see the repos you have. pejman New Member yum is the best way, i run on Ubuntu 14.0.4 LTS, i have installed yum before but don't know how i activate repositories Code: root@test:~# yum install pcre-devel

yes checking for strftime... (cached) yes checking which regex library to use... I'm trying to get gd installed but I'm getting this error after installing it: PHP Warning: PHP Startup: Unable to load dynamic library '/opt/phpbrew/php/php-5.4.22/lib/php/extensions/debug-non-zts-20100525/gd.so' - /opt/phpbrew/php/php-5.4.22/lib/php/extensions/debug-non-zts-20100525/gd.so: undefined symbol: libiconv_open in Unknown With regards, Alex. ✔ Professional Server Management for web hosting companies and individuals ✔ Hourly Support, Disaster Recovery, Server Hardening, Monthly Subscription ✔ Directadmin installation and optimization Click here if you php checking whether to enable LIBXML support...

That wouldn't affect anything on your system. [2015-08-25 11:33 UTC] rainer-phpbugs at 7val dot com This is a problem with the pcre supplied with w.g. Is scroll within a card good or bad? (In desktop) What is the truth about 1.5V "lithium" cells Were defendants at the Nuremberg trial allowed to deny the holocaust? make 2>&1 >> /opt/phpbrew/build/php-5.4.22/build.log ext/iconv/.libs/iconv.o: In function _php_iconv_appendl': /opt/phpbrew/build/php-5.4.22/ext/iconv/iconv.c:401: undefined reference tolibiconv' /opt/phpbrew/build/php-5.4.22/ext/iconv/iconv.c:438: undefined reference to libiconv' ext/iconv/.libs/iconv.o: In functionphp_iconv_string': /opt/phpbrew/build/php-5.4.22/ext/iconv/iconv.c:494: undefined reference to libiconv_open' /opt/phpbrew/build/php-5.4.22/ext/iconv/iconv.c:506: undefined reference tolibiconv' /opt/phpbrew/build/php-5.4.22/ext/iconv/iconv.c:524: undefined