Home > Error Could > Error Could Not Find File /etc/usb_modeswitch.setup

Error Could Not Find File /etc/usb_modeswitch.setup

Now check the file in /usr/share/usb_modswitch you will find a tar file in it which contain some information about your device. I can live with manually making the command to connect. Waiting for original device to vanish ... Terms Privacy Security Status Help You can't perform that action at this time. http://strobelfilms.com/error-could/error-could-not-find-the-file-flash-ocx.html

You have to reboot your system for the changes to have effect Vanamali (vanamalishastry) said on 2013-09-06: #15 Thank you very much for the help! in the end, i have tested a live usb by installing usb_modeswitch 2.2.0 and it works fine. You can begin by using the command "lsmod" both without and with the modem plugged in to check that a kernel module is being loaded. Thanks user@ubuntu:~$ ls /etc/usb_modeswitch.d/ 0421:060c 0af0:7011 0af0:d033 12d1:101e 19d2:0103 0421:0610 0af0:7031 0af0:d035 12d1:1031 19d2:0115 0471:1210 0af0:7051 0af0:d055 12d1:1414 19d2:1001 0471:1237 0af0:7071 0af0:d057 12d1:1446 19d2:1007 0482:024d 0af0:7111 0af0:d058 12d1:14ad 19d2:1009 04e8:689a 0af0:7211 http://www.draisberghof.de/usb_modeswitch/bb/viewtopic.php?t=608

Look for your device file in the tar file, you will get it there. searching devices, found USB ID 03f0:241d searching devices, found USB ID 138a:0007 searching devices, found USB ID 8087:0020 searching devices, found USB ID 19d2:2000 found matching vendor ID found matching product libusbx: error [op_clear_halt] clear_halt failed error -1 errno 71 libusbx: error [op_clear_halt] clear_halt failed error -1 errno 71 OK, message successfully sent Reset response endpoint 0x81 Could not reset endpoint (probably

nothing should be stopping it now!!!!!!!!!!!!!! Optical Mouse Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub And It is also detected by nm-applet or say by using nmcli as follows: $ nmcli dev list fail: -------------------------------- (end of usb_modeswitch output) All done, exiting I think the ID that this message shows in the beginning (19d2:2000) does not match the ID from lsusb (19d2:2003), see earlier You will have to register before you can post in the forums. (Be aware the forums do not accept user names with a dash "-") Also, logging in lets you avoid

Wait for device file system (1 sec.) ... This is from the device_reference.txt file available on usb_modeswitch site: ######################################################## # ZTE MF622 (aka "Onda MDC502HS") # ZTE MF626 # ZTE MF628+ (tested version from Telia / Sweden) # ZTE Waiting for original device to vanish ... http://www.linuxquestions.org/questions/linux-hardware-18/connecting-usb-3g-dongle-device-as-modem-852447/ searching devices, found USB ID 04f3:0230 searching devices, found USB ID 8087:0020 Searching for target devices ...

E173 3G Modem (modem-mode) And Now: Bus 001 Device 003: ID 12d1:1446 Huawei Technologies Co., Ltd. 1552/E1800/E173 (HSPA modem) And now the modem isn't detected in nm-applet (nor listed by nmcli). Sep 5 19:51:29 Shastry modem-manager[954]: (ttyUSB0) opening serial port... that script is not an ubuntu script, it is a mobile partner driver. searching devices, found USB ID 147e:2016 searching devices, found USB ID 1d6b:0001 searching devices, found USB ID 1d6b:0001 searching devices, found USB ID 1d6b:0001 searching devices, found USB ID 0471:1210 found

It works fine on Windows. https://forums.opensuse.org/showthread.php/476616-Setting-up-mobile-broadband-with-HUAWEI-E3131/page3 How do I answer a question on graduate school applications on textbooks used in my classes, when my class didn't use a textbook? The compiling environment is not all ready. Exit" SafeExit } Log "ConfigList: $configList" # Check if there is more than one config file for this USB ID, # which would make an attribute test necessary.

Earlier ( about 7 days ago) I started another thread and got some ideas from Josh but got nowhere. http://strobelfilms.com/error-could/error-could-not-find-tsearch2-sql-file.html Anyone using Slackware knows much more about linux than I do; all I do is look it up. I then followed the instructions for install. I really am stuck so any help would be appreciated....

ZTE MF636 I am using Ubuntu 10.04.2. But it is unfortunate that most of the broadband vendors are providing support and drivers only for Windows platform. The perfect solution is to revert to default condition as explained in question. this content On Monday or Tuesday I will have more news.Regards,Jerzy Offline #4 2015-04-21 15:42:42 carongangoo Member Registered: 2014-10-22 Posts: 58 Re: Incorrect USB Modeswitch?

Isix View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by Isix 12-26-2010, 05:39 PM #5 thorkelljarl Senior Member Registered: Jun 2008 Posts: So annoyed. Other tutorials from naveen No other tutorials.

No idea why though.

By the way, the script is looking for "kernel-default" but if this is a laptop you are likely to have "kernel-desktop" instead. Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 22 Star 79 Fork 42 Trixarian/sakis3g-source Code Issues 2 Pull requests 0 Projects At the moment, I have to plug in the device, eject it, then it gets recognised as a modem. Must work share|improve this answer edited Jan 1 '15 at 14:33 Pandya 4,85552469 answered Dec 30 '14 at 23:37 elbarna 2,46541532 Yes, I tried it and is working fine.

However, there are certain ways in which we can make these broadband devices work in Linux as well. ACTION=="add", ATTRS{idVendor}=="XXXX", ATTRS{idProduct}=="UUUU", RUN+="/home/user/script.sh" Replace XXXX and UUUU with vendor and id product,put rule in /etc/udev/rules.d/99-yourrule.rules and reboot or restart udev. the only time the modem was working was when i have tried to install that mobile partner thing. have a peek at these guys thorkelljarl View Public Profile View LQ Blog View Review Entries View HCL Entries Find More Posts by thorkelljarl 12-26-2010, 10:47 AM #3 bryanl Member Registered: Dec 2003 Posts: 96

So open /etc/usb_modeswitch.conf and look for a line containing ;TargetProduct= 0x0031 Remove semi-colon (;) from start of the following lines ;DefaultVendor= 0x19d2 ;DefaultProduct= 0x2000 ;TargetVendor= 0x19d2 ;TargetProduct= 0x0031 # only for Ask a question Edit question Subscribers Subscribe Subscribe someone else • Take the tour • Read the guide © 2004-2016 CanonicalLtd. • Terms of use • Contact Launchpad Support • damn thing alexfishMarch 13th, 2011, 05:16 PMhi can try and modprobe serial driver sudo modprobe usbserial vendor=0x12d1 product=0x1c05 if this works then will post details of how to do udev rules The ID number(19d2:2003) is the key to finding out more; this ID/chip is used for more than one brand(ONDA,ZTE).

fs/super.c : "Self-destruct in 5 seconds. When I type usb_modeswitch in the terminal, it says can't find /etc/use_modeswitch.conf. –oshirowanen May 19 '11 at 18:25 I'm using Ubuntu 10.04.2, you're possibly using a different version of Waiting for original device to vanish ... To this minute, I am still fighting this battle.

asked 5 years ago viewed 12645 times active 3 years ago Linked 2 how to make 3G USB Modem work with ubuntu? Well, I have never used these new ncm huaweis but I think that NO extra driver NOR script is needed, at least for basic internet connection, as post #13 seems to