Home > Dependent Module > Dependent Module /usr/lib/libodbcinst.so Could Not Be Loaded

Dependent Module /usr/lib/libodbcinst.so Could Not Be Loaded

Contents

Also you can try to type 'unset LIBPATH' before starting agent. This package contains a copy of libodbc.a in /usr/lib which is incompatible with the ODBC libraries shipped with and used by MicroStrategy. Log in to reply. Any help would be appreciated. this contact form

Most suggest that this error is a result of 32 bit vs. 64 bit drivers.I have verified we are using 32 bit for everything. Unfortunately, I have so far found no way of compiling and providing YUM for AIX that could be done in a compatible manner (to the IBM provided RPM) as AIX still Code: $ cd /opt/IBM/mqsi/6.0/xml4c/lib64 $ ar -t libicuuc32.0.a ar: 0707-108 File libicuuc32.0.a is not an archive file. I hope seeing this you can give some idea. .profile excerpt Code: . /opt/IBM/mqsi/6.0/bin/mqsiprofile PATH=/usr/bin:/etc:/usr/sbin:/usr/ucb:$HOME/bin:/usr/bin/X11:/sbin:/opt/IBM/mqsi/6.0/bin:/home/mqm/sqllib/bin:/app1/install/u sr/mqm/bin:. http://www.unix.com/unix-for-advanced-and-expert-users/173759-aix-dependent-module-could-not-loaded.html

Dependent Module Libclntsh.so Could Not Be Loaded

Dependent module /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1) could not be loaded. Unable to connect. When i try to execute isql, i am getting the error below. Some places in PC documentation, it refers to .odbc.ini but it should be odbc.ini.Also as suggested earlier please try ldd commands.

Remove advertisements Sponsored Links zaxxon View Public Profile Find all posts by zaxxon #5 01-04-2012 Clovis_Sangrail Registered User Join Date: Dec 2011 Last Activity: 28 October 2016, 2:17 Show 6 replies 1. Kindly post your $ODBCINI file, so we can see where the problem is. 0509-026 System Error: A File Or Directory In The Path Name Does Not Exist The easiest way to download the files contained in a RPM dependency list would be using wget.

Smitty fails to repush firefox bundle and the client started production before noticing the browser break so I can't rebuild OS. 0509-026 System Error: Cannot Run A File That Does Not Have A Valid Format If you really need functionality of gettext >= 0.10.40 (the version compatible with the original AIX Toolbox for Linux applications) you should install the gettext-progs package that provides the binaries of Can you do me a favor, by being more specific? http://www.mqseries.net/phpBB2/viewtopic.php?t=36129 While searching for the Magic number problem, I came across with a solution similar to the problem but for the odbc.so.

The solution says that the problem can be resolved by creating the symbolic link between odbc.so and libodbc.so. Dependent Module Libttsh11.so Could Not Be Loaded Log in to reply. In this case you should check the following items: Make sure that your autoconf, automake, libtool, m4 versions are not older than January, 2008! This is info from their website.http://www.easysoft.com/support/kb/kb00940.html Follow the steps at the end to create the file needed.******The actual error reported to us was:0509-150 Dependent module /usr/local/easysoft/unixODBC/lib/libodbc.a(odbc.so) could not be loaded.

0509-026 System Error: Cannot Run A File That Does Not Have A Valid Format

Resolving these kinds of path problems can be tricky - you probably want to open a PMR with IBM support._________________I am *not* the model of the modern major general. http://mailman.unixodbc.org/pipermail/unixodbc-support/2016-January/003622.html you are using an old version of that program/package that is still linked against gettext version 0.17: I was so unhappy about the gettext issue described further below that I completely Dependent Module Libclntsh.so Could Not Be Loaded Easysoft Data Access Why do I get error "libodbc.a(odbc.so) could not be loaded"? 0509-022 Cannot Load Module Updated on 2013-08-13T13:19:04Z at 2013-08-13T13:19:04Z by micheri igtoth 270005E8Q3 2 Posts Re: unable launch the firefox browser on AIX 6.1 ‏2014-05-18T03:58:00Z This is the accepted answer.

This is the accepted answer. weblink Any help is greatly appreciated. dump: /tmp/ldd1892686/extract/libiconv.so.2: 0654-106 Cannot open the specified file. /usr/lib/libperfstat.a(shr.o) /unix /usr/lib/libcrypt.a(shr.o) /usr/lib/libpthreads.a(shr_xpg5.o) /usr/lib/libcfg.a(shr.o) /usr/lib/libodm.a(shr.o) /usr/lib/liblvm.a(shr.o) /usr/lib/libpthreads.a(shr_comm.o) metro01 /usr/sbin #ls -la /usr/lib/libc.a lrwxrwxrwx 1 bin bin 19 Jul 24 2005 /usr/lib/libc.a -> But I am again getting the same result. Dependent Module Libskgxp11.so Could Not Be Loaded

Therefore, if you get the following error message ... 0509-150 Dependent module /opt/freeware/lib/libintl.a(libintl.so.8) could not be loaded. 0509-152 Member libintl.so.8 is not found in archive ... Can you explain this Magic Number problem. the libiconv.a/so is found in the installation package "bos.rte.iconv": > lslpp -L bos.rte.iconv Fileset Level State Type Description (Uninstaller) ---------------------------------------------------------------------------- bos.rte.iconv 5.3.7.0 C F Language Converters State codes: C -- Committed. http://strobelfilms.com/dependent-module/dependent-module-could-not-be-loaded.html I'm a consultant at this firm, and while I've been given root access to this machine I probably need to notify people who will get monitoring alerts & such before I

bash-4.2# firefox Could not load program /usr/mozilla/firefox/firefox-bin: Could not load module /opt/freeware/lib/libfontconfig.a(libfontconfig.so.1). Dependent Module Libons.so Could Not Be Loaded. Error type: System call error. then you must be alerted because then in the earlier output you should have seen the following lines: ...

bbb.rpm has dependency on ddd.rpm and ccc.rpm on eee.rpm and fff.rpm.

Yes, it is entirely possible that I'm running into some kind of version incompatibility issue. I ran the ldd command and this is what is showed me.bash-3.00$ ldd libpmodbc.alibpmodbc.a needs:/data/infa/ODBC420/lib/libodbc.a(odbc.so)ar: 0707-108 File /data/infa/ODBC420/lib/libodbc.a is not an archive file.dump: /tmp/tmpdir176308/extract/odbc.so: 0654-106 Cannot open the specified file./data/infa/RepositoryServer/libpmi18n.a/data/infa/RepositoryServer/libpmdec.a/data/infa/RepositoryServer/libpmasrt.a/data/infa/RepositoryServer/libpmser.a/data/infa/RepositoryServer/libpmuti.a/data/infa/RepositoryServer/libpmodl.a/usr/lib/libC.a(shr.o)/usr/lib/libC.a(shr2.o)/usr/lib/libC.a(ansi_32.o)/usr/lib/libpthreads.a(shr_xpg5.o)/usr/lib/libc.a(shr.o)/data/infa/RepositoryServer/libglobalcS.a/usr/lib/libc_r.a(shr.o)/data/infa/RepositoryServer/libtls4dshr.a(shr.o)/usr/lib/libdl.a(shr.o)/usr/lib/libC.a(ansicore_32.o)/usr/lib/libC.a(shrcore.o)/usr/lib/libC.a(shr3.o)/usr/lib/libpthreads.a(shr_comm.o)/unix/usr/lib/libcrypt.a(shr.o) Is Running dump -H on unixODBC's isql included with your Easysoft ODBC driver might display: INDEX PATH BASE MEMBER 3 libodbc.a libodbc.so.1 Applications such as Informatica and UniVerse/UniData have a dependency on 0509-150 Dependent Module Libimbcmdlib.a(libimbcmdlib.a.so) Could Not Be Loaded and this is an AIX-specific issue.

I have added the following entries into the /etc/environment file (LIBPATH=/usr/lib ; LD_LIBRARY_PATH=:/usr/lib:/lib:/usr/local/lib) as recommended by IBM when dealing with the missing iconv fileset. Has anybody ever encountered something like this? wget gives warning message about libidn and libiconv wget produces a warning message similar to this one: # wget ... http://strobelfilms.com/dependent-module/dependent-module-libclntsh-a-could-not-be-loaded.html Unanswered question This question has not been answered yet.

This is the accepted answer. So I have specifically specified the lib path and then export the LD_LIBRARY_PATH. I installed db2 client which comes with odbc driver and i also installed unix odbc driver manager (both of them installed as OS user dbclient). Back to top raghuvanshiankur Posted: Fri Apr 06, 2007 7:51 am    Post subject: NoviceJoined: 18 Aug 2006Posts: 23Location: IN Dear Jeff, As you rightly said that .profile should source all the

It sounds like, perhaps, your pre-supplied mqsiprofile may not be set up correctly. Show: 10 25 50 100 items per page Previous Next Feed for this topic [unixODBC-support] Unable to get isql working on AIX 7.1 Sundar Mahadevan sundarmahadevan82 at gmail.com Thu Jan 21 This is actually where a tool like yum is helping you a lot because it does all the steps outlined above for you. It seems that libiconv library (package) is not installed.

Edit - History - Print - Recent Changes - Search Page last modified on November 05, 2013, at 02:42 PM Grokbase › Groups › MySQL › odbc › November 2010 FAQ lewd26-01-2010, 15:25We ran into the exactly same problem with our installation of Zabbix Agent 1.8 on IBM AIX 5.3 (ML-07). Newer versions of rpm.rte at least issue a statement during installation like that: Warning: the contents of the following RPM packages will be overwritten. At various stages in unixODBC's history, libtool (used to create unixODBC shared objects) has created:libodbc.a(libodbc.so)libodbc.a(libodbc.so.1) Applications linked against the library are dependent on the name of the archive (libodbc.a) and the

Thank you again. I am getting a similar error: bash-4.2# firefox exec(): 0509-036 Cannot load program /usr/mozilla/firefox/firefox-bin because of the following errors: 0509-022 Cannot load module /usr/lib/libcairo.a(libcairo.so.2). 0509-150 Dependent module /usr/lib/libXrender.a(libXrender.so.1) could