Home > Dependent Module > Dependent Module Libexpat.a Libexpat.so.0 Could Not Be Loaded

Dependent Module Libexpat.a Libexpat.so.0 Could Not Be Loaded

Contents

at /u/unilocal/perl-5.8.0-site/lib/aix/XML/Parser.pm line 15 Compilation failed in require at /u/unilocal/perl-5.8.0-site/lib/aix/XML/Parser.pm line 15. bbb.rpm has dependency on ddd.rpm and ccc.rpm on eee.rpm and fff.rpm. This can become quite annoying and time-consuming for packages with lots of dependencies. Regards, Jeff Jul 25 '07 #2 reply P: 1 Balthes Silly, question, but do you have the XML::parser module installed on the machine? this contact form

at /usr/opt/perl5/lib/site_perl/AIX/XML/Parser.pm line 15 We searched for libexpat.so in the file system and did not find it.   We also did not find the Expat module installed on AIX 5.3.   rpm -q How is that only lib file I am missing in /usr/lib because I have all libaprutil-1.so and libaprutil-1.so.0. I was finally able to get it to decrypt properly. How do I get the one I need on my system? here

Dependent Module Libclntsh.so Could Not Be Loaded

wget gives warning message about libidn and libiconv wget produces a warning message similar to this one: # wget ... Aaron, 2008-07-03 Comment 1 Aaron 2008-07-05 19:48:51 UTC Hi, This problem has been resolved.When you configure the apache,you can add the flag of '--enable-shared=no'. $./configure --prefix=/home/viador/apache2 --enable-so --enable-ssl --with-ssl=/usr/local/ssl --with-expat=builtin --enable-shared=no PerlMonks was recently assimilated by The Perl Foundation. This seems kind of silly to me.

apxs:Error: Command failed with rc=65536 make: 1254-004 The error code from the last command is 1. versions instead. node historyNode Type: perlquestion [id://879788]Approved by Corionhelp Chatterbox? and all is quiet... Dependent Module Libskgxp11.so Could Not Be Loaded. Aaron, 2008-07-06 Comment 2 Eric Covener 2009-05-25 07:38:23 UTC Original issue: You have to set the native shared library path if you want to move files around.

module and showing that in another path. (i.e) Error below: bash-2.05b$ /u/unilocal/perl-5.8.0/bin/perl xxx.plx configfiles/psd/xxxx.xml Can't load '/u/unilocal/perl-5.8.0-site/lib/aix/auto/XML/Parser/Expat/Expat.so' for module XML::Parser::Expat: 0509-022 Cannot load module /u/unilocal/perl-5.8.0-site/lib/aix/auto/XML/Parser/Expat/Expat.so. I have not yet tried rebooting this system. So that would be the first thing to check. https://techscores.wordpress.com/2010/04/20/hello-world/ You download all the RPM packages on this list (make sure that you have downloaded them all into a separate directory which was empty before).

thanks, Ashish Remove advertisements Sponsored Links shriashishpatil View Public Profile Find all posts by shriashishpatil #7 01-11-2012 Clovis_Sangrail Registered User Join Date: Dec 2011 Last Activity: 28 October Dependent Module Libttsh11.so Could Not Be Loaded Please check with rpm -ql /path/to/apr-util-1.3.4-1.aix5.1.ppc.rpm if the library is in there and what its path is. 0 Message Author Comment by:AIX25 ID: 250830932009-08-12 This is unbelievable!! If you are experiencing a similar issue, please ask a related question Suggested Solutions Title # Comments Views Activity Using SFTP to transfer file from RHEL to Windows Client - using Password Home Search Forums Register Forum RulesMan PagesUnix Commands Linux Commands FAQ Members Today's Posts UNIX for Advanced & Expert Users Expert-to-Expert.

0509-026 System Error: Cannot Run A File That Does Not Have A Valid Format

So you end up circling through all your RPM files and downloading all prerequisite RPM files just to install aaa.rpm. https://bz.apache.org/bugzilla/show_bug.cgi?id=45329 Table of contents Compatibility issue with the original AIX Toolbox for Linux Applications A solution to the RPM dependency hell problem I am getting an error message that a dependent module Dependent Module Libclntsh.so Could Not Be Loaded They're available here - http://www.perzl.org/aix/index.php?n=Main.Apr and here - http://www.perzl.org/aix/index.php?n=Main.Apr-util Look for the 'Even older version' headings. 0 Message Author Comment by:AIX25 ID: 250834152009-08-12 I have installed apr and apr-utils 0509-022 Cannot Load Module This generally involves dismounting the file system, backing it up to tapes, and restoring it to a new partition.

Then you had me install an older apr and apr-util. http://strobelfilms.com/dependent-module/dependent-module-libibmldap-a-could-not-be-loaded.html On a regular basis, I'm most likely to spy upon: My spouse My children My pets My neighbours My fellow monks Wild Animals Anybody Nobody Myself Spies Can't tell (I'm NSA/FBI/HS/...) Connect with top rated Experts 9 Experts available now in Live! No package released since July 2009 should need gettext 0.17 anymore! 0509-026 System Error: A File Or Directory In The Path Name Does Not Exist

at /usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi/XML/Parser.pm line 14 Compilation failed in require at /usr/opt/perl5/lib/site_perl/5.8.2/aix-thread-multi/XML/Parser.pm line 14. Newer versions of rpm.rte at least issue a statement during installation like that: Warning: the contents of the following RPM packages will be overwritten. Just an idea. http://strobelfilms.com/dependent-module/dependent-module-could-not-be-loaded.html The easiest way to download the files contained in a RPM dependency list would be using wget.

Are you sure that it can't be found in another place, too? Dependent Module Libons.so Could Not Be Loaded. Those are the required steps (in the example I use AIX 6.1 and please note that the exact version numbers might vary): Download httpd-2.4.3-1.aix5.1.ppc.deps and mod_php_ap24-5.4.6-1.aix5.1.ppc.deps from ftp://www.oss4aix.org/rpmdb/deplists/aix61 Then combine those In case of aix, .a and .so are not same as on other unix systems.

This is actually where a tool like yum is helping you a lot because it does all the steps outlined above for you.

rpms are too new. Could not load module /home/viador/apache2/lib/libexpat.a(libexpat.so.0). If these packages did not come from the AIX Toolbox for Linux Applications, it may be necessary to reinstall them. 0509-150 Dependent Module Libimbcmdlib.a(libimbcmdlib.a.so) Could Not Be Loaded Join our community for more solutions or to ask questions.

What is especially unfortunate and what I don't understand is why rpm.rte (especially the rpm command) is not compiled with private shared libraries in some private directory -- which would be at /usr/opt/perl5/lib/5.8.2/aix-thread-multi/DynaLoader.pm line 229. soubalaji has asked for the wisdom of the Perl Monks concerning the following question: Hi, Currently iam using unix for running perl. his comment is here no checking whether to build static libraries...

Did you use rpm -i --nodeps ... ?? I still don't understand where /usr/HTTPServer/lib/libaprutil-0.so suddenly came from! Could not load module . They're available here - http://www.perzl.org/aix/index.php?n=Main.Apr Go to Solution 11 10 2 Participants AIX25(11 comments) woolmilkporc(10 comments) LVL 68 Unix OS53 21 Comments LVL 68 Overall: Level 68 Unix OS 53

Thx for the points! Join & Ask a Question Need Help in Real-Time? Dependent module /export/home/oracle/apache2/lib/libaprutil-0.so could not be loaded. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old. - Increase transparency - Onboard new hires faster - Access from mobile/offline Try

Similar topics xml parsing script dying with "Premature end of script headers" error Error parsing web.config file error C1004 Visual Studio 2005 - external build, error parsing error in upload images bzip2-1.0.5-1 gettext-0.17-1 info-4.12-1 zlib-1.2.3-5 A solution to the RPM dependency hell problem I guess everybody who has installed a couple of RPM packages using rpm itself and not the help with I do need to try that, though. To be completed....

chmod 755 /home/viador/apache2/modules/mod_jk.so chmod: /home/viador/apache2/modules/mod_jk.so: A file or directo ry in the path name does not exist. error while parsing XML file in AIX P: 3 sherihan2007 Hi while am running perl script which parses an XML file in AIX following error is getting:(i have given use XML::parser P.S. Whatever!

Whenever the rpm.rte AIX LPP gets updated -- for whatever reason, e.g., a technology level update -- problems may arise if you have installed newer versions of the following three packages Starting with version 1.12 GNU wget added support for Internationalized Resource Identifiers (IRIs, RFC 3987).